Trying for transmission swap - Dodge Dakota Forum : Custom Dakota Truck Forums
Noobie Introductions If your new to the site, this is the place to meet everyone and tell us about yourself and truck.

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-19-2020, 09:09 PM Thread Starter
Forum Member
 
Join Date: Oct 2020
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Points: 3, Level: 1 Points: 3, Level: 1 Points: 3, Level: 1
Activity: 0% Activity: 0% Activity: 0%
Trying for transmission swap

I'm having issues with my 05 Dakota v6 automatic overheating. I've cleaned cooling system replaced thermostat twice, replaced water pump, and replaced fan clutch. Now I've also having issues when it gets around normal running temperature my transmission won't shift on up which in turn runs me much higher rpm and of course start causing my coolant to start boiling out of the overflow. I have a transmission out of a 02 1500 with a v8 and would like to put it in my 05 Dakota with a v6, of course both automatic. Can anyone tell me if this is possible and if there is anything else I need to do to make it possible.
Sean Lankford is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-28-2020, 03:17 PM
Forum Member
 
Join Date: Oct 2020
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Points: 5, Level: 1 Points: 5, Level: 1 Points: 5, Level: 1
Activity: 0% Activity: 0% Activity: 0%
It is terrible that you have an issue eith your 05 Dakota v6, I hope you found out the good mechanics.
Thomson9 is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
no new posts