Dodge Dakota Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Has any one experianced this or had similar problems. I have an intermetant problem with my tranny. It is a 98 4spd automatic over drive in my dakota only 74k miles. I have AEM Intake and full exhaust so the engine is putting out more power than it did at stock.

The problem is at about 40 to 45mph the rpms jump up and down about 500 rpm. The jump is so bad it makes the whole truck buck. Any ideas as to what is going on is apreciated. I checked the throtle linkange thinking they are hanging up but they are free and clear.
Michael
 

·
Smurf
Joined
·
263 Posts
i need to know how many rpms you are running when it does it and in what gear the tranny is in.
try manually shifting through the gears and see if it still does it if it dosent you computer that controls your shifting is bad it sounds like it may be trying to revup to much to prepair to shift
my other instinct is ti say that you are having a chip problem but you havent said if you put a chip in it other than that i would say take it to a shop and get it put on a computer and see if they can troubleshoot it for you
in the mean time i will round up some of my mechanics and we will fire up the computers and see what we can come up with for you if you give me a couple of days i can have an answer fer you
 

·
Premium Member
Joined
·
397 Posts
I had something similar, but not quite as extreme. It happend at about 70 mph and just drop a couple hundred rpms.I changed out the throttle position sensor and everything was fine.
 

·
Smurf
Joined
·
263 Posts
ok here is the best i can come up with for now try the throtle position sensor first because it is cheeper ($25.99 autozone) if that dont fix it then try the tranny control unit which is dealer only and i havent been able to get a price on it yet but it is a computer so i am thinkin not cheep (upwards of $150 w/o labor) it is on you from here i have one other source that i am tryin to get ahold of as i type he is my book of knowledge on this usually but i cant get him on the phone b/c he was off today as soon as i get his input i will lay it out on here for you

this is mechanic A85 out
 

·
Registered
Joined
·
27 Posts
Well DAMN! I had a similar experience just last night. I was coming home doing about 70-75 and after I finally got off the e-way and to a red light, the engine was still revved up. What is that? Do I need a throttle position sensor? Help me out guys
 

·
Smurf
Joined
·
263 Posts
yours sounds to me like you neet to check your throttle linkage and make sure it isnt gettin hung up also make sure it slides freely in and out make sure you have someone handy in the truck when you are checkin it to turn it off if it sticks so you dont blow it up or fuck up your head seals


the other strange thing i am gonna say is did you have your cruse on on th e way i had one experience where that was the problem?

hit me back and let me know if you had it on and i will explain to you what we had to do
 

·
Registered
Joined
·
27 Posts
Well I didnt have the cruise control on, I'm not sure if i even have it. Most of the time, I'm too busy droppin' my truck's ass at redlights that I s dont even think about it. I'm going to get my bro to help me out with your suggestions, thanx, bubba
 

·
Registered
Joined
·
27 Posts
hey bubba, it was the throttle linkage! I but some wd40 on it and I used my hand to twist and release it, and it is as smooth as hell! No problems at all now, thanks for the help. 5 really appreciate it. Hey bubba, what kind of bags were on the front of the original smokin' dakota? I blew a bag and need to replace it as well as the vavles, any suggestions on that?
 

·
Smurf
Joined
·
263 Posts
not sure off the top of my head but you can ask admin (it was his truck) to find out we will see if he can get back to you with the answer before i do
 

·
Smurf
Joined
·
263 Posts
ok i do not know all i know is that the 2-link in the rear was done by totallypollished.com but i will let steve know you were wonderin and see if he wont post it up and let you know.
 

·
Smurf
Joined
·
263 Posts
i know his 2000 dak he had had 2500's on all 4 corneres and he was lookin at 2600's up front on that one but that isnt what you asked i know the origonal smokin dakota was a '97 but i am gonna bet it was 2500's too usually when you build a second truck of the same kind you use parts you have used before and that you like and you know work
 

·
Premium Member
Joined
·
397 Posts
I think they were firestones. If not they were contitechs. Let me guess, it was the driver side front bag? I had a problem with that one rubbing. I trimmed the spring pocket before I sold it to try to solve the problem. You should see where the bag is rubbing and trim it out some more.
 

·
Premium Member
Joined
·
397 Posts
Oh, and they were 2500's all the way around.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #16 ·
Bubba I am sorry its taken me so long to get back. I have not had anymore trouble with the truck until last night. I was racing aginst a supra. Just as I got a truck lenght ahead of him doing 80 the truck started bucking again. This time the rpms where at 3000 dead on when the jump hit. Again a 500 rpm jump then a complete loss of power until it took off again. The throttel was all the way down full open. Thanks Michael
 

·
Smurf
Joined
·
263 Posts
ok i would now take it and have it looked at you are talkin about a problem that could either seriously skrew up your investment or cause an accident
i am still thinkin tranny problem but i am not for sure you might just need to replace the throttle linkage but it might be worse if you get on dodges website you can look up and see if there is a recall out on your truck that fits the problem discription but you need to get it figured out soon b4 you have a serioys problem or accident
 
1 - 17 of 17 Posts
Top